App

Download the PlatoApp  

In order to start your PlatoWork session, you will need the PlatoApp.  You can download it from one of the app stores below. 

 

 

Smartphone capabilities

iOS: 10.0 minimum version
Android: Lollipop minimum version

After downloading the app, please go to Settings > Update PlatoWork headset to ensure that your headset has the latest firmware installed.